Skip to main content

"Failed to configure vAPI Endpoint Service at the firstboot time" while installing Windows VC 6.5

 

Symptoms
While configuring the vAPI EndPoint Service, you experience these symptoms:
  • Windows vCenter Server 6.5 installation fails while configuring the vAPI EndPoint Service
  • vCenter Server 6.5 installation on a Windows Server fails during the vAPI EndPoint Service during the firstboot time.
  • You see the error:

    Error: An error occurred while starting service 'vapi-endpoint'. Failed to start the vAPI Endpoint Service. Failed to configure vAPI Endpoint Service at the firstboot time. Please file a bug against VAPI
     
  • In vapi_firstboot.py_2948_stderr.log file, you see entries similar to:

    No valid files with pathname: C:\ProgramData\VMware\vCenterServer\logs\vapi\endpoint* found.
    ERROR starting vapi-endpoint rc: 2, stdout: , stderr: Start service request failed. Error: Service crashed while starting^M
    vapi firstboot failed
    Traceback (most recent call last):
    File "C:\Program Files\VMware\vCenter Server\firstboot\vapi_firstboot.py", line 536, in sys.exit(Main())
    File "C:\Program Files\VMware\vCenter Server\firstboot\vapi_firstboot.py", line 514, in Main vapi_firstboot()
    File "C:\Program Files\VMware\vCenter Server\firstboot\vapi_firstboot.py", line 502, in vapi_firstboot actionFirstboot(fbObj)
    File "C:\Program Files\VMware\vCenter Server\firstboot\vapi_firstboot.py", line 480, in actionFirstboot actionStart(fbObj)
    File "C:\Program Files\VMware\vCenter Server\firstboot\vapi_firstboot.py", line 485, in actionStart startService(msg, fbObj)
    File "C:\Program Files\VMware\vCenter Server\firstboot\vapi_firstboot.py", line 361, in proxy return func(args, *kwargs)
    File "C:\Program Files\VMware\vCenter Server\firstboot\vapi_firstboot.py", line 429, in startService fbObj.start_services()
    File "C:\Program Files\VMware\vCenter Server\firstboot\vapi_firstboot.py", line 225, in start_services self.start_service()
    File "C:\Program Files\VMware\vCenter Server\python-modules\cis\firstboot.py", line 272, in start_service service_start(self.get_eff_service_name())
    File "C:\Program Files\VMware\vCenter Server\python-modules\cis\utils.py", line 742, in service_start
    "localized": "Failed to configure vAPI Endpoint Service at the firstboot time",
    "translatable": "Failed to configure vAPI Endpoint Service at the firstboot time"

     
  • In the Firstbootinfrastructure logs file, you see entries similar to:

    WARNING firstbootInfrastructure Bug component info file does not exist
    INFO firstbootInfrastructure Firstboot duration: 178 sec
    INFO firstbootInfrastructure First boot is a failure

     
  • LDAP client receives this error:

    com.vmware.identity.interop.ldap.WinLdapClientLibrary, error code: 32
Cause
This issue occurs if there is a restriction in running Java.
 
Resolution
To resolve this issue:
  1. Ensure that the Domain login used to install vCenter Server has full Administrator privilege.
  2. Modify the group policies under the Software Restriction Policies section in the group/machine policy and allow permissions for Java.

Comments

Popular posts from this blog

Increasing the disk space for the VMware vCenter Server Appliance in vSphere 6.5, 6.7 and 7.0

  Purpose This article provides steps to increase the disk space of a specific VMDK for the vCenter Server Appliance 6.5, 6.7 and 7.0. With the introduction of Logical Volume Management (LVM) in vSphere 6.0 and continued support with vSphere 6.5, 6.7 and 7.0, the vCenter Server disks can be dynamically increased. List of VMDKs for a vCenter Server Appliance 6.5 - Size Mount point and Purpose Note : Resizing the root partition (VMDK1 listed in the KB above) is not supported on 6.5. Please see the vSphere 6.5 Release Notes for more information. Resizing root partition has been added to 6.7 and 7.0. List of VMDKs/Partitions for a vCenter Server Appliance 6.7 - Size Mount point and Purpose   List of VMDKs/Partitions for a vCenter Server 7.0 - Size Mount point and Purpose Note : This KB can be used for the situation like SEAT partition full or any other vCenter appliance partition full. ...

Cloning and converting virtual machine disks with vmkfstools

 Purpose This article provides information and instructions on the use of the vmkfstools command to convert virtual machine disks from one type to another. Resolution The vmkfstools command offers the ability to clone virtual machine content and also convert from one virtual machine disk ( .vmdk ) format into another. Note : The host operating system chosen to perform the conversion may not necessarily support running of virtual machines via the output format defined. vmkfstools maintains the possibility of exporting virtual disks for use in other VMware products which support alternative disk formats. To convert a virtual machine disk from one type to another: Shut down the virtual machine. Virtual machine disk files are locked while in-use by a running virtual machine. Log in to the VMware vSphere Management Assistant (v...

Investigating virtual machine file locks on ESXi

      Details Adding an existing virtual machine disk (VMDK) to a virtual machine that is already powered on fails.                 Failed to add disk scsi0:1. Failed to power on scsi0:1   Powering on the virtual machine results in the power on task remaining at 95% indefinitely. Cannot power on the virtual machine after deploying it from a template. Powering on a virtual machine fails with an error: Unable to open Swap File Unable to access a file since it is locked Unable to access a file <filename> since it is locked Unable to access Virtual machine configuration In the /var/log/vmkernel log file, you see entries similar to: WARNING: World: VM xxxx: xxx: Failed to open swap file <path>: Lock was not free WARNING: World: VM xxxx: xxx: Failed to initialize swap file <path>   When opening a console to the virtual machine, you may receive ...