Skip to main content

High CPU usage in vCenter Server Appliance 6.7

 


 
 
  Symptoms
  • Increase of CPU usage after upgrading to vCenter Server Appliance 6.7.
  • Slow performance when do operations in vSphere Client (HTML5) and vSphere Web Client (Flex).
  • In the Monitor > Performance tab, the CPU usage of VCSA 6.7 may be more than 90%.
Cause
In this case the root cause of high CPU usage in VCSA 6.7 is the Jetty, a Java HTTP server, which is used by the vSphere Update Manager integrated in VCSA. The Open source Jetty has reported multiple issues with high CPU usages. Read more information about this known issue of Jetty from 100% CPU usage in Selector using Jetty
Resolution
This is a known issue and plan to fix in vSphere 6.7 P03.
To workaround the issue, 
1. SSH login to vCenter Server Appliance.
2. Edit the file config.conf:
# vi /etc/vmware-vsan-health/config.conf
3. At the end of this file, add the below content:
[KillSwitch]
VumIntegration = False
4. Restart the service of vmare-vsan-health
# service-control --stop vmware-vsan-health
# service-control --start vmware-vsan-health

How to identity if high CPU usage issue matched the case, please follow the steps:
1. SSH login to VCSA.
2. List the PID of process which consumes the most of CPU
# ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%cpu | head
  PID  PPID  CMD                          %MEM  %CPU
46852  6953  jre/bin/java -Dhttps.protoc  25.7   771

3. Display the running command information of the process:
# ps axww opid,etime,cmd | grep <PID>
In the above sample, the PID is 46852. The sample cmdlet is:
# ps axww opid,etime,cmd | grep 46852
The output of the cmdlet is similar with below:
 46852  8-03:38:11 jre/bin/java -Dhttps.protocols=TLSv1 -Djavax.net.ssl.trustStore=ssl/vmware-vum.keystore -Djetty.home=jetty/ -Djetty.base=jetty/ -Djetty.port=9084 -Djetty.ssl.port=9087 -Dvum.sdk.port=8084 -Dvum.installdir=/usr/lib/vmware-updatemgr/bin/ -Dvum.patchstore=/storage/updatemgr/patch-store/ -Dvum.patchstore.temp=/storage/updatemgr/patch-store-temp/ -Djava.io.tmpdir=/storage/updatemgr/jetty-temp -Djetty.logs=/var/log/vmware/vmware-updatemgr/vum-server/ -Dlog4j.configuration=jetty/resources/log4j.properties -jar jetty/wrapper.jar jetty-vum.xml jetty-vum-ssl.xml jetty/etc/jetty-https.xml --pre=jetty/etc/jetty-logging.xml

To immediately remediate high CPU usage, you can run below actions:
1. Kill the Jetty process:
# kill -9 PID
2. Restart vmware-updatemgr service
# service-control --stop vmware-updatemgr
# service-control --start vmware-updatemgr

Comments


  1. It is very useful information for a tech support, thank you for giving such significant info about the CPU.
    Apart from this, there may be more problems with the computer, so for that, I would like you to take our help,
    we have helpline support which is the only stop for all your software and hardware problems.
    for more detail please visit us on our website given below:-
    Helpline Support US

    ReplyDelete

Post a Comment

Popular posts from this blog

Increasing the disk space for the VMware vCenter Server Appliance in vSphere 6.5, 6.7 and 7.0

  Purpose This article provides steps to increase the disk space of a specific VMDK for the vCenter Server Appliance 6.5, 6.7 and 7.0. With the introduction of Logical Volume Management (LVM) in vSphere 6.0 and continued support with vSphere 6.5, 6.7 and 7.0, the vCenter Server disks can be dynamically increased. List of VMDKs for a vCenter Server Appliance 6.5 - Size Mount point and Purpose Note : Resizing the root partition (VMDK1 listed in the KB above) is not supported on 6.5. Please see the vSphere 6.5 Release Notes for more information. Resizing root partition has been added to 6.7 and 7.0. List of VMDKs/Partitions for a vCenter Server Appliance 6.7 - Size Mount point and Purpose   List of VMDKs/Partitions for a vCenter Server 7.0 - Size Mount point and Purpose Note : This KB can be used for the situation like SEAT partition full or any other vCenter appliance partition full. ...

Cloning and converting virtual machine disks with vmkfstools

 Purpose This article provides information and instructions on the use of the vmkfstools command to convert virtual machine disks from one type to another. Resolution The vmkfstools command offers the ability to clone virtual machine content and also convert from one virtual machine disk ( .vmdk ) format into another. Note : The host operating system chosen to perform the conversion may not necessarily support running of virtual machines via the output format defined. vmkfstools maintains the possibility of exporting virtual disks for use in other VMware products which support alternative disk formats. To convert a virtual machine disk from one type to another: Shut down the virtual machine. Virtual machine disk files are locked while in-use by a running virtual machine. Log in to the VMware vSphere Management Assistant (v...

Investigating virtual machine file locks on ESXi

      Details Adding an existing virtual machine disk (VMDK) to a virtual machine that is already powered on fails.                 Failed to add disk scsi0:1. Failed to power on scsi0:1   Powering on the virtual machine results in the power on task remaining at 95% indefinitely. Cannot power on the virtual machine after deploying it from a template. Powering on a virtual machine fails with an error: Unable to open Swap File Unable to access a file since it is locked Unable to access a file <filename> since it is locked Unable to access Virtual machine configuration In the /var/log/vmkernel log file, you see entries similar to: WARNING: World: VM xxxx: xxx: Failed to open swap file <path>: Lock was not free WARNING: World: VM xxxx: xxx: Failed to initialize swap file <path>   When opening a console to the virtual machine, you may receive ...