Skip to main content

vsan-health service not starting : "An error occurred while starting service 'vsan-health'"

  Symptoms

  • vsan-health service not starting : "An error occurred while starting service 'vsan-health'"
  • vSAN related logs will not capture the actual error.
  • vMon log will also give any hint on the failure. 
  • Checking vmware-vsan-health-runtime.log.stderr gives the following trace
Starting service process with pid: 542.
Traceback (most recent call last):
  File "/usr/lib/vmware-vpx/vsan-health/VsanMgmtServer.py", line 382, in <module>
    SetupLogging(gCmdOptions, logdir)
  File "/usr/lib/vmware-vpx/vsan-health/VsanMgmtServer.py", line 194, in SetupLogging
    Logger.InitLogging(logDir)
  File "/usr/lib/vmware-vpx/vsan-health/logger/Logger.py", line 295, in InitLogging
    SetupLoggers(loggerConfFile, logDir)
  File "/usr/lib/vmware-vpx/vsan-health/logger/Logger.py", line 273, in SetupLoggers
    configInFile = UpdateFormatterHandlerPath(f)
  File "/usr/lib/vmware-vpx/vsan-health/logger/Logger.py", line 231, in UpdateFormatterHandlerPath
    config = json.load(configFile)
  File "/usr/lib/python3.5/json/__init__.py", line 268, in load
    parse_constant=parse_constant, object_pairs_hook=object_pairs_hook, **kw)
  File "/usr/lib/python3.5/json/__init__.py", line 319, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.5/json/decoder.py", line 339, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.5/json/decoder.py", line 357, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)
Cause
This issue can happen if the logger.conf is corrupted
Impact / Risks
  • VAMI based backups will fail since the service is stopped.
  • vSAN monitoring information would not be available.
Resolution
To resolve the issue.

1. Change Directory: cd /etc/vmware-vsan-health
2. Move the file logger.conf to another location.
mv logger.conf /var/tmp/logger.conf

3. Once done, try restarting the service : 
vmon-cli -r vsan-health

Comments

Popular posts from this blog

Increasing the disk space for the VMware vCenter Server Appliance in vSphere 6.5, 6.7 and 7.0

  Purpose This article provides steps to increase the disk space of a specific VMDK for the vCenter Server Appliance 6.5, 6.7 and 7.0. With the introduction of Logical Volume Management (LVM) in vSphere 6.0 and continued support with vSphere 6.5, 6.7 and 7.0, the vCenter Server disks can be dynamically increased. List of VMDKs for a vCenter Server Appliance 6.5 - Size Mount point and Purpose Note : Resizing the root partition (VMDK1 listed in the KB above) is not supported on 6.5. Please see the vSphere 6.5 Release Notes for more information. Resizing root partition has been added to 6.7 and 7.0. List of VMDKs/Partitions for a vCenter Server Appliance 6.7 - Size Mount point and Purpose   List of VMDKs/Partitions for a vCenter Server 7.0 - Size Mount point and Purpose Note : This KB can be used for the situation like SEAT partition full or any other vCenter appliance partition full. ...

Cloning and converting virtual machine disks with vmkfstools

 Purpose This article provides information and instructions on the use of the vmkfstools command to convert virtual machine disks from one type to another. Resolution The vmkfstools command offers the ability to clone virtual machine content and also convert from one virtual machine disk ( .vmdk ) format into another. Note : The host operating system chosen to perform the conversion may not necessarily support running of virtual machines via the output format defined. vmkfstools maintains the possibility of exporting virtual disks for use in other VMware products which support alternative disk formats. To convert a virtual machine disk from one type to another: Shut down the virtual machine. Virtual machine disk files are locked while in-use by a running virtual machine. Log in to the VMware vSphere Management Assistant (v...

Investigating virtual machine file locks on ESXi

      Details Adding an existing virtual machine disk (VMDK) to a virtual machine that is already powered on fails.                 Failed to add disk scsi0:1. Failed to power on scsi0:1   Powering on the virtual machine results in the power on task remaining at 95% indefinitely. Cannot power on the virtual machine after deploying it from a template. Powering on a virtual machine fails with an error: Unable to open Swap File Unable to access a file since it is locked Unable to access a file <filename> since it is locked Unable to access Virtual machine configuration In the /var/log/vmkernel log file, you see entries similar to: WARNING: World: VM xxxx: xxx: Failed to open swap file <path>: Lock was not free WARNING: World: VM xxxx: xxx: Failed to initialize swap file <path>   When opening a console to the virtual machine, you may receive ...